FreeBSD 上面的 PHP 4.4.1

我只能說, 這個版本是顆大地雷.
除非系統是自己開發, 而且程式碼都寫得很漂亮, 不然用 4.4.0 還是比較好.

之前幫某台機器升級, 結果上面的 phpBB 就爛了… orz
Error message 長這個樣子:

PHP Fatal error: Cannot redeclare get_userdata() in xxx.php on line xxx

後來是靠 portdowngrade ( 在 /usr/ports/sysutils/portdowngrade ) 把版本換回 4.4.0 , 指令上大致上是這樣 :

cd /usr/ports/sysutils/portdowngrade
make install clean
rehash
portdowngrade -o -s \\
:pserver:anoncvs@anoncvs.at.FreeBSD.org:/home/ncvs lang/php4

然後會出現一些問題給你選, 弄好以後用 portupgrade -f 把已安裝的這兩種開頭的軟體全部洗一遍就好:

  1. php4-*
  2. pecl-*

:roll:

Tweet 20
fb-share-icon20